Issues with AML lookups at sub-processor (Signicat)

Incident Report for AdminFlow

Resolved

This incident has been resolved.
Posted Sep 25, 2026 - 09:19 CEST

Update

We are continuing to work on a fix for this issue.
Posted Sep 25, 2026 - 09:17 CEST

Identified

Our sub-processor Signicat is currently experiencing issues affecting AML lookups in the AML module. Lookups may fail or take longer than usual. We are monitoring the situation closely and will post an update as soon as we have more information. All other parts of Adminflow are operating normally.
Posted Sep 24, 2026 - 12:08 CEST
This incident affected: Third party Integrations.